Vicibox 9.0.1 Installation Issues

All installation and configuration problems and questions

Moderators: gerski, enjay, williamconley, Op3r, Staydog, gardo, mflorell, MJCoate, mcargile, Kumba, Michael_N

Vicibox 9.0.1 Installation Issues

Postby iboam » Sat Mar 14, 2020 2:17 pm

i have installed this new version several times with different issues every time, first had issues with certbot (that need ACME v2 and can't find where to get it), did a reinstall and now asterisk does not run, sometimes apache does not load. does anyone have the same issues with this version 9.0.1 ???

Unable to connect to remote asterisk (does /var/run/asterisk/asterisk.ctl exist?)
Certbot binary not installed at /usr/bin/certbot
ViciBox: 8.1.2 | VERSION: 2.14-711a BUILD: 190607-1525 | Clusters: 1 DB-WEB / 3 ASTX | SSL | WebRTC | Wallboard | DNC Nightly Scrubber
iboam
 
Posts: 233
Joined: Mon Feb 08, 2016 2:35 pm

Re: Vicibox 9.0.1 Installation Issues

Postby Ajay22 » Mon Mar 16, 2020 1:24 am

Hi Iboam,

even im getting asterisk issue with Vicidial 9.0.1, I have tried re installing 4 to 5 times all times i have got asterisk issue Unable to connect to remote asterisk (does /var/run/asterisk/asterisk.ctl exist?)

Before 1 month its was working fine with 9.0.1 ISO now they have updated the Vicidial built Ver also recently due to that asterisk is not working or might be bug occurring while capturing the updated via zypper up and zypper refresh comments while installing the software,

All this issue same im facing from last week when they have made some changes.
VERSION: 2.14-738a | BUILD: 200210-1628 | Asterisk Version: 13.29.2-vici | SVN Version: 3198 | Cloud Server: Rackspace | Configuration: 8 Core 8 GB RAM 320 GB SSD | Installation Method: Vicibox 9.1 ISO
Ajay22
 
Posts: 7
Joined: Mon Jan 13, 2020 3:10 am

Re: Vicibox 9.0.1 Installation Issues

Postby iboam » Mon Mar 16, 2020 1:42 am

Thanks for your response. i had to instal Vicibox 8.1.2 and get an wildcard ssl certificate from www.ssls.com, very easy to install, now everything is up and running even webrtc phone. This is the first time in years that i have issues with vicidial.

They do an awesome job to keep this free !!!
ViciBox: 8.1.2 | VERSION: 2.14-711a BUILD: 190607-1525 | Clusters: 1 DB-WEB / 3 ASTX | SSL | WebRTC | Wallboard | DNC Nightly Scrubber
iboam
 
Posts: 233
Joined: Mon Feb 08, 2016 2:35 pm

Re: Vicibox 9.0.1 Installation Issues

Postby bourneshell » Sun Mar 29, 2020 6:20 am

For the certbot issue you need to do 2 things

1. Change the URL where the HTTP01 request will be requested.
2. Update the authenticator setting and force it to use standalone.

Below is a quick script you can use
Code: Select all
sed -i 's/acme-staging/acme-v02/g' /etc/letsencrypt/cli.ini
sed -i 's/authenticator = webroot/authenticator = standalone/g' /etc/letsencrypt/cli.ini


As for the asterisk issue I came across this issue as well the other day and found that there maybe an issue with the latest update of DAHDI. If you run zypper up before doing the vicibox-install script you need to disable zypper from updating the DAHDI and Asterisk packages. To do this you can run the command below

Code: Select all
zypper al dahdi* asterisk* kernel*


I also added the kernel on the package locks so that when you run zypper up it won't be updating those packages.
https://www.dialer.host/
bourneshell
 
Posts: 27
Joined: Mon May 14, 2018 12:55 pm


Return to Support

Who is online

Users browsing this forum: Nefariousparity and 56 guests