Vicibox 8.0.1 11.25.1-vici

Support forum for the ViciBox ISO Server Install and ISO LiveCD Demo

Moderators: enjay, williamconley, Staydog, mflorell, MJCoate, mcargile, Kumba

Vicibox 8.0.1 11.25.1-vici

Postby Nefariousparity » Fri Feb 28, 2020 8:25 pm

The following item is locked and will not be changed by any action:
Available:
pattern:apparmor

The following 6 package updates will NOT be installed:
asterisk asterisk-dahdi asterisk-snmp dahdi-linux dahdi-linux-kmp-default perl-IO-Socket-SSL

Is it not longer possible to get the upgrade to 11.25.3-vici?


bt6-t9:~ # zypper dup --allow-vendor-change
Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.
Retrieving repository 'openSUSE-Leap-42.3-PERL' metadata ......................................................................................................................[error]
Repository 'openSUSE-Leap-42.3-PERL' is invalid.
[openSUSE-Leap-42.3-PERL|http://download.opensuse.org/repositories/devel:/languages:/perl/openSUSE_Leap_42.3/] Valid metadata not found at specified URL
Please check if the URIs defined for this repository are pointing to a valid repository.
Warning: Skipping repository 'openSUSE-Leap-42.3-PERL' because of the above error.
Retrieving repository 'openSUSE-Leap-42.3-Server-Database' metadata ...........................................................................................................[error]
Repository 'openSUSE-Leap-42.3-Server-Database' is invalid.
[openSUSE-Leap-42.3-Server-Database|http://download.opensuse.org/repositories/server:database/openSUSE_Leap_42.3/] Valid metadata not found at specified URL
Please check if the URIs defined for this repository are pointing to a valid repository.
Warning: Skipping repository 'openSUSE-Leap-42.3-Server-Database' because of the above error.
Some of the repositories have not been refreshed because of an error.
Loading repository data...
Warning: Repository 'openSUSE-Leap-42.3-Update' appears to be outdated. Consider using a different mirror or server.
Reading installed packages...
Computing distribution upgrade...
5 Problems:
Problem: nothing provides libosptk-4.13.0.so()(64bit) needed by asterisk-11.25.3-107.40.x86_64
Problem: nothing provides libosptk-4.13.0.so()(64bit) needed by asterisk-11.25.3-107.40.x86_64
Problem: nothing provides libosptk-4.13.0.so()(64bit) needed by asterisk-11.25.3-107.40.x86_64
Problem: wanpipe-kmp-default-7.0.20.12_k4.4.132_53-10.15.x86_64 requires ksym(default:_dahdi_receive) = 1bbd693, but this requirement cannot be provided
Problem: dahdi-linux-kmp-default-2.11.1_k4.4.76_1-6.1.x86_64 requires dahdi-linux = 2.11.1-6.1, but this requirement cannot be provided

Problem: nothing provides libosptk-4.13.0.so()(64bit) needed by asterisk-11.25.3-107.40.x86_64
Solution 1: deinstallation of asterisk-11.25.1-102.2.x86_64
Solution 2: keep obsolete asterisk-11.25.1-102.2.x86_64
Solution 3: break asterisk-11.25.3-107.40.x86_64 by ignoring some of its dependencies

Choose from above solutions by number or skip, retry or cancel [1/2/3/s/r/c] (c):
|| DB Schema Version: 1582 || Asterisk 13.29.2-vici || BUILD: 191121-2256 ||VERSION: 2.14-730a||SVN: 3182||6xTelephony||1x Database||1x Slave||1x Web||1x Archive||ViciBox v.9.0.1
Nefariousparity
 
Posts: 295
Joined: Wed Sep 12, 2012 7:01 pm

Re: Vicibox 8.0.1 11.25.1-vici

Postby williamconley » Fri Feb 28, 2020 8:34 pm

1) None of your repositories worked. Thus not being able to provide a dependency is not a surprise, really.
2) Why are you still using 8.0.1 if you want an upgrade? Install with 8.1.2 for a later version, since that will install a later version of asterisk. Or 9.0.1 if you're feeling brave, it seems stable now ... albeit very different from earlier versions.
3) Why do you want to upgrade asterisk? Are you bored? 8-)
Vicidial Installation and Repair, plus Hosting and Colocation
Newest Product: NonDisruptive Lead Loader for Enterprise Vicidial Clusters.
(IE: Keep on dialing even while loading large lists!)
http://www.PoundTeam.com # 352-269-0000 # +44(203) 769-2294
williamconley
 
Posts: 19396
Joined: Wed Oct 31, 2007 4:17 pm
Location: Davenport, FL (By Disney!)

Re: Vicibox 8.0.1 11.25.1-vici

Postby Nefariousparity » Fri Feb 28, 2020 10:16 pm

Its a long story, I have done 9.0.1 which works great. But we do the whole separate database partition thing and that seemed like not a option during install install. Awhile back I can't remember I went to upgrade and Answering machine detection, was claimed to be broken by a great many people using asterisk 13. If I can do 8.1.2, and do asterisk 11, and the repos work awesome! 11-25-3 is where I would prefer to stay.

**Edit, I would like to add that I built 8 servers last night, and only these four amazingly were finally broken enough to where I could not squeeze out these last few updates.
|| DB Schema Version: 1582 || Asterisk 13.29.2-vici || BUILD: 191121-2256 ||VERSION: 2.14-730a||SVN: 3182||6xTelephony||1x Database||1x Slave||1x Web||1x Archive||ViciBox v.9.0.1
Nefariousparity
 
Posts: 295
Joined: Wed Sep 12, 2012 7:01 pm

Re: Vicibox 8.0.1 11.25.1-vici

Postby Nefariousparity » Fri Feb 28, 2020 11:51 pm

Well just tried 8.1.2, and then prior to Vicidial doing the vicibox-ast11 roll back. It also massively errored out, of course I did this in KVM. I also did do updates prior to this? But at this point I'm feeling there is no hope for asterisk 11-25-3 anymore.

https://imgur.com/VF3lFJp
|| DB Schema Version: 1582 || Asterisk 13.29.2-vici || BUILD: 191121-2256 ||VERSION: 2.14-730a||SVN: 3182||6xTelephony||1x Database||1x Slave||1x Web||1x Archive||ViciBox v.9.0.1
Nefariousparity
 
Posts: 295
Joined: Wed Sep 12, 2012 7:01 pm

Re: Vicibox 8.0.1 11.25.1-vici

Postby williamconley » Sat Feb 29, 2020 12:09 am

maybe you should just not do the updates? Why are you updating asterisk?
Vicidial Installation and Repair, plus Hosting and Colocation
Newest Product: NonDisruptive Lead Loader for Enterprise Vicidial Clusters.
(IE: Keep on dialing even while loading large lists!)
http://www.PoundTeam.com # 352-269-0000 # +44(203) 769-2294
williamconley
 
Posts: 19396
Joined: Wed Oct 31, 2007 4:17 pm
Location: Davenport, FL (By Disney!)

Re: Vicibox 8.0.1 11.25.1-vici

Postby Nefariousparity » Sat Feb 29, 2020 12:12 am

Well I was going to add some additional servers to these clusters, I typically roll the updates, to 11.25-3. Now I'm stuck because the rest of the cluster is 11.25.3, and these will be 11.25.1 Maybe there is not much difference between the two? And I can sneak them in.







-
|| DB Schema Version: 1582 || Asterisk 13.29.2-vici || BUILD: 191121-2256 ||VERSION: 2.14-730a||SVN: 3182||6xTelephony||1x Database||1x Slave||1x Web||1x Archive||ViciBox v.9.0.1
Nefariousparity
 
Posts: 295
Joined: Wed Sep 12, 2012 7:01 pm

Re: Vicibox 8.0.1 11.25.1-vici

Postby williamconley » Sat Feb 29, 2020 12:19 am

There is ZERO need to match asterisk version between servers.
Vicidial Installation and Repair, plus Hosting and Colocation
Newest Product: NonDisruptive Lead Loader for Enterprise Vicidial Clusters.
(IE: Keep on dialing even while loading large lists!)
http://www.PoundTeam.com # 352-269-0000 # +44(203) 769-2294
williamconley
 
Posts: 19396
Joined: Wed Oct 31, 2007 4:17 pm
Location: Davenport, FL (By Disney!)

Re: Vicibox 8.0.1 11.25.1-vici

Postby Nefariousparity » Sat Feb 29, 2020 12:21 am

Well that is great news! I always worked very hard at keeping all things the same! William Conley. Thank you very much! Now if we could turn my attention to database partitioning on vicibox 9.0.1 all of this might be a moot point. As always, thank you sir!
|| DB Schema Version: 1582 || Asterisk 13.29.2-vici || BUILD: 191121-2256 ||VERSION: 2.14-730a||SVN: 3182||6xTelephony||1x Database||1x Slave||1x Web||1x Archive||ViciBox v.9.0.1
Nefariousparity
 
Posts: 295
Joined: Wed Sep 12, 2012 7:01 pm

Re: Vicibox 8.0.1 11.25.1-vici

Postby williamconley » Sat Feb 29, 2020 12:29 am

why partition? why not just replicate?
Vicidial Installation and Repair, plus Hosting and Colocation
Newest Product: NonDisruptive Lead Loader for Enterprise Vicidial Clusters.
(IE: Keep on dialing even while loading large lists!)
http://www.PoundTeam.com # 352-269-0000 # +44(203) 769-2294
williamconley
 
Posts: 19396
Joined: Wed Oct 31, 2007 4:17 pm
Location: Davenport, FL (By Disney!)

Re: Vicibox 8.0.1 11.25.1-vici

Postby alo » Sat Feb 29, 2020 6:35 pm

11.25.1-vici Crashes several times a day for me. So I always upgrade to asterisk 11.25.3. But I noticed as of 5 days ago I started getting that error too when adding additional dialing servers.

even moving the repos to 15.1 like I used to do to force the repos to work stopped working. I know they have stopped supporting a bunch of the repos, but I think it might be that an even newer version of asterisk 11.25.3.X.X.X was released requiring a newer version of libosptk or something.

I would love to figure this out too.
alo
 
Posts: 142
Joined: Wed Jun 20, 2012 10:21 am

Re: Vicibox 8.0.1 11.25.1-vici

Postby williamconley » Sat Feb 29, 2020 6:49 pm

alo wrote:I think it might be that an even newer version of asterisk 11.25.3.X.X.X was released requiring a newer version of libosptk or something.

more likely libosptk changed. vicidial did not alter the already published older asterisk version. underlying requirements, however, often change and asterisk has dependencies.

you could try the asterisk version from here http://download.vicidial.com/packages/ and see if that works for you. Remember that it's not about the version, it's about whether it's stable in your environment. ANY version of asterisk from 1.2 to 13 will work if your Vicidial core is recent enough to support it (it always supports older versions, it's newer versions that they obviuosly can't anticipate in advance, lol). so you could install vicibox 5.X and it would still work with that very old asterisk version just fine. And stable.

speaking of which: you could try "noloading" modules you're not using or even debugging the crash to see if you can find which module is responsible and just kill that one if you're not using it. for instance, the cdrdb or sqlite could be the culprit and you don't need either one of them.

williamconley wrote:why partition? why not just replicate?
Vicidial Installation and Repair, plus Hosting and Colocation
Newest Product: NonDisruptive Lead Loader for Enterprise Vicidial Clusters.
(IE: Keep on dialing even while loading large lists!)
http://www.PoundTeam.com # 352-269-0000 # +44(203) 769-2294
williamconley
 
Posts: 19396
Joined: Wed Oct 31, 2007 4:17 pm
Location: Davenport, FL (By Disney!)


Return to ViciBox Server Install and Demo

Who is online

Users browsing this forum: Google [Bot] and 10 guests