SOLVED - Leave 3-way button not working

Support forum for the ViciBox ISO Server Install and ISO LiveCD Demo

Moderators: enjay, williamconley, Staydog, mflorell, MJCoate, mcargile, Kumba

SOLVED - Leave 3-way button not working

Postby kamirie » Wed Jul 15, 2015 4:22 pm

Good Day,

We are doing warm trannsfer to an external number to the US , We can have a succesful transfer by putting the number and clickng "dial with customer " the transfer will be completed but after like a minute or so , the agent warning will pop up with " dial timed out , contact system admin...." even though the transfer is already connected. And we can't leave the 3 way as when we click leave-3way , nothing happens. Blind transfer is working but we need warm transfer for the campaign.

CLI : of a completed transfer . Nothing seems to iniate on CLI when we click leave-3-way
Code: Select all
[Jul 16 05:14:01]   == Manager 'sendcron' logged off from 127.0.0.1
[Jul 16 05:14:05]   == Manager 'sendcron' logged on from 127.0.0.1
[Jul 16 05:14:05]     -- Executing [0818666040758@default:1] AGI("Local/0818666040758@default-00000048;2", "agi://127.0.0.1:4577/call_log") in new stack
[Jul 16 05:14:05]     -- <Local/0818666040758@default-00000048;2>AGI Script agi://127.0.0.1:4577/call_log completed, returning 0
[Jul 16 05:14:05]     -- Executing [0818666040758@default:2] Dial("Local/0818666040758@default-00000048;2", "SIP/astar/18666040758,,tTo") in new stack
[Jul 16 05:14:05]   == Using SIP RTP CoS mark 5
[Jul 16 05:14:05]     -- Called SIP/astar/18666040758
[Jul 16 05:14:06]   == Manager 'sendcron' logged on from 127.0.0.1
[Jul 16 05:14:06]   == Manager 'sendcron' logged off from 127.0.0.1
[Jul 16 05:14:08]     -- SIP/astar-0000004a is making progress passing it to Local/0818666040758@default-00000048;2
[Jul 16 05:14:11]     -- SIP/astar-0000004a answered Local/0818666040758@default-00000048;2
[Jul 16 05:14:11]     -- Executing [8600052@default:1] MeetMe("Local/0818666040758@default-00000048;1", "8600052,F") in new stack
[Jul 16 05:14:11]     -- Executing [h@default:1] AGI("Local/0818666040758@default-00000048;2", "agi://127.0.0.1:4577/call_log--HVcauses--PRI-----NODEBUG-----16-----ANSWER-----6-----0") in new stack
[Jul 16 05:14:11]     -- <Local/0818666040758@default-00000048;2>AGI Script agi://127.0.0.1:4577/call_log--HVcauses--PRI-----NODEBUG-----16-----ANSWER-----6-----0 completed, returning 0
[Jul 16 05:14:11]   == Spawn extension (default, 0818666040758, 2) exited non-zero on 'Local/0818666040758@default-00000048;2'
[Jul 16 05:14:11]   == Manager 'sendcron' logged off from 127.0.0.1
[Jul 16 05:14:12]   == Manager 'sendcron' logged off from 127.0.0.1
[Jul 16 05:15:01]   == Manager 'sendcron' logged on from 127.0.0.1
[Jul 16 05:15:01]   == Manager 'sendcron' logged on from 127.0.0.1
Last edited by kamirie on Thu Jul 16, 2015 12:56 pm, edited 1 time in total.
Vicibox 6.0.3
http://download.vicidial.com/iso/vicibo ... nstall.pdf
VERSION: 2.12-492a
BUILD: 150701-1131

Single Server
Amd opteron Quad Core @ 3.0 Ghz
8GB RAM
kamirie
 
Posts: 84
Joined: Tue Dec 27, 2011 7:46 pm

( SOLVED )Re: Leave 3-way button not working

Postby kamirie » Thu Jul 16, 2015 12:56 pm

This is now have been solved following this posts

Must manualy update asterisk version in Admin > Servers to your correct astersk version


http://www.vicidial.org/VICIDIALforum/v ... =8&t=30118
Vicibox 6.0.3
http://download.vicidial.com/iso/vicibo ... nstall.pdf
VERSION: 2.12-492a
BUILD: 150701-1131

Single Server
Amd opteron Quad Core @ 3.0 Ghz
8GB RAM
kamirie
 
Posts: 84
Joined: Tue Dec 27, 2011 7:46 pm

Re: SOLVED - Leave 3-way button not working

Postby farhan.nazim » Thu Feb 13, 2020 5:02 am

Leave 3-way button is working now

my Dial Plan

exten => _1X.,1,Set(CALLERID(all)=18569524890)
exten => _1X.,2,AGI(agi://127.0.0.1:4577/call_log)
exten => _1X.,3,Dial(SIP/${EXTEN}@Vinvound,,tTo)
exten => _1X.,4,Hangup

Changed in first line (all) to (num) my issue is resolved
exten => _1X.,1,Set(CALLERID(num)=18569524890)
exten => _1X.,2,AGI(agi://127.0.0.1:4577/call_log)
exten => _1X.,3,Dial(SIP/${EXTEN}@inbound,,tTo)
exten => _1X.,4,Hangup
farhan.nazim
 
Posts: 4
Joined: Fri Jul 12, 2019 7:47 am

Re: SOLVED - Leave 3-way button not working

Postby williamconley » Thu Feb 20, 2020 3:28 am

Good postback. 8-)
Vicidial Installation and Repair, plus Hosting and Colocation
Newest Product: NonDisruptive Lead Loader for Enterprise Vicidial Clusters.
(IE: Keep on dialing even while loading large lists!)
http://www.PoundTeam.com # 352-269-0000 # +44(203) 769-2294
williamconley
 
Posts: 19399
Joined: Wed Oct 31, 2007 4:17 pm
Location: Davenport, FL (By Disney!)


Return to ViciBox Server Install and Demo

Who is online

Users browsing this forum: No registered users and 11 guests