No outgoing in manual dial

All installation and configuration problems and questions

Moderators: gerski, enjay, williamconley, Op3r, Staydog, gardo, mflorell, MJCoate, mcargile, Kumba, Michael_N

No outgoing in manual dial

Postby anoop.kr » Tue Mar 21, 2023 4:01 am

Hi,
My vicidial server sits behind an Alcatel exchange, I have successfully configured my vicdial throgh SIP to the Alcatel. I can make outgoing calls from vicidial (using microsip) through Alcatel, all is fine. But I cannot make outgoing calls through vicidial dial interface, followed some tutorials from youtube (https://www.youtube.com/watch?v=JZSXp8R ... olxmbx8MYZ) to configure, created users, phones, campaigns etc. when I dial through vicidial interface, the asterisk cli shows nothing indicating that call, but when I call by microsip asterisk cli shows logs properly, somehow vicidial is not able to connect to asterisk ? Tried with disabling firewall. When I login as an agent microsip springs in to action but after that asterisk cli is idle.
Can you help me ? Any help is greatly appreciated.

Asterisk : Asterisk 16.30.0-vici
Version :vicibox10 (Installed from official ISO)
Virtualbox VM
sip show peers :
Name/username Host Dyn Forcerport Comedia ACL Port Status Description
88001/88001 10.40.41.193 D Yes Yes 61951 OK (1 ms)
oxesip 10.41.12.203 Yes Yes 5060 OK (2 ms)

Regards
Anoop
anoop.kr
 
Posts: 28
Joined: Tue Mar 07, 2023 6:47 am

Re: No outgoing in manual dial

Postby jamiemurray » Tue Mar 21, 2023 1:51 pm

If there's absolutely no output in asterisk cli when you make a call via Vicidial, next thing I'd check is are all the required screen sessions running?

You'll need at the very least the following:

Code: Select all
~ # screen -ls
There are screens on:
        11820.ASTVDauto (Detached)
        9162.ASTVDadapt (Detached)
        31667.ASTlisten (Detached)
        31664.ASTsend   (Detached)
        31661.ASTupdate (Detached)
        25446.asterisk  (Detached)
        25439.astshell20221207012104    (Detached)
        20085.ASTfastlog        (Detached)


There may be a few others there, but each of the ones above is the minimum required for a functioning Vicidial system.

I'm going to guess one or more of these are not running, the question then becomes, why not?
Usually asterisk has crashed or is running as a service (not started by the vicidial startup script) this will cause cascading failures of some of the scripts you see (or don't) running in a screen session.

If any are missing, run the following and post the output:
Code: Select all
/usr/share/astguiclient/ADMIN_keepalive_ALL.pl --debugX
Skype: live:support_71847 | Tel: (US) +1 646 647 8850 (CA) +1 613 900 6456 (MX) +52 55 9990 3550 (UK) +44 1324 285022 (ES) +34 922 937 384
Managed Hosting - No tech skills required | VoIP Termination & DID numbering | https://jmurraysolutions.com
jamiemurray
 
Posts: 177
Joined: Fri Jan 11, 2013 4:12 pm
Location: Tenerife, Canary Islands

Re: No outgoing in manual dial

Postby anoop.kr » Tue Mar 21, 2023 11:47 pm

Hiii,
Thanks for your kind reply and valuable time, in the end it turned out to be the problem of dial plan entries created in CARRIER settings, as a direct call from the softphone itself was working alright my though was vicidial shall follow too. I was under pressure, so desperately searching for a solution, got a hint from elsewhere and tried and it worked, thanks anyway.

Regards
anoop
anoop.kr
 
Posts: 28
Joined: Tue Mar 07, 2023 6:47 am


Return to Support

Who is online

Users browsing this forum: Google [Bot] and 63 guests