Agents not getting calls from queue vicidial-2.9.44

All installation and configuration problems and questions

Moderators: gerski, enjay, williamconley, Op3r, Staydog, gardo, mflorell, MJCoate, mcargile, Kumba, Michael_N

Agents not getting calls from queue vicidial-2.9.44

Postby tarikzz » Tue Apr 24, 2018 2:19 pm

Hello,

First of all, thank you so much for the fantastic work that is being made here. Both the product and the active guys on the forum are great. I already found the answers to a lot of questions in this forum, but now I have a tricky problem that keeps us from increasing the traffic because customers are waiting way too long.

Some details about the install. Please apologize if some details are missing, as this is my first post here.
Vicidial-2.9.441a-140612.1628.2.go | Asterisk 1.8.23.0-1_centos5.go RPM |CentOS release 5.11
load average: 0.14, 0.15, 0.10
4 to 6 agents in real-time, up to 20 calls in queue.
Agents only receive calls on their hardphones. Some of the calls are blind-transferred by the agents to an external SIP server and some other calls are simply hung up by the agent.
There is only one campaign. Two in-groups, but all agents are activated on all in-groups. And several DIDs, coming from different carriers, each DIDs is configured to one of the DIDs.

The problem is that although we have a lot of calls in queue, most of the time the available agents cannot get them, and just stay waiting. There are few phones ringing, but the communication got cut immediately when the agent picks up, and then the agent waits again. When i call directly the extensions of the agents, it works.

I've been working on this problem for quite a bit, and I followed the following three leads:

First lead : Few days ago when we started working, we already met what seemed to be the same issue, that we fixed by adding few more lines of :
Code: Select all
exten => _8331*.,n,AGI(agi-VDAD_RINGALL.agi,${EXTEN})

This hack was found here in this forum, because someone had the same problem. One more symptom we shared with this guy: both of us experienced that calls to softphones where OK, but not on some specific hardphones. Adding this lines did the trick.
But now, we are again in the same trouble. I tried to add even more lines of RINGALL in extensions.conf, but unsuccessfully.

Second lead: I noticed that agents status in "agent monitoring" section were "CLOSER" and not "READY". I think I understood the meaning of CLOSER, explained in this forum as being a status allowing, for example, great sellers to get only specific non-cold sales on the phone, but it is not our case, our agents are all simply supposed to handle the same incoming traffic. Could this CLOSER status keep us from getting the calls from the queue?

Last lead. Another post I found that seemed to be related to my problem: viewtopic.php?f=2&t=26827&p=94303
In this post, the on-hold prompt is mentioned as a possible reason for calls being held in the queue when the on-hold file is too long. Verified: I don't have any on-hold file.


Many thanks in advance for any clue you might have in order to help our agents to directly get the calls from the queue without waiting time.

All the best
Linux vicibox8 4.4.140-62-default #1 SMP Tue Jul 17 12:14:34 UTC 2018 (951943d) x86_64 x86_64 x86_64 GNU/Linux
Asterisk 11.25.3-vici
Maria DB 10.2.16-MariaDB-log. Apache/2.4.23 (Linux/SUSE) PHP 5.5.14
RAM 32G
CPU x8 3.50GHz
tarikzz
 
Posts: 13
Joined: Sun Apr 15, 2018 8:02 am

Re: Agents not getting calls from queue vicidial-2.9.44

Postby williamconley » Tue Apr 24, 2018 3:11 pm

That's a long post. No time to read all of it. lol. Please do post your method of installation, however, that may be useful. Also consider upgrading (and/or explain why you can't).

Thoughts:

1) Verify that none of these calls are going to voicemail. This is often a killer on ringall. Note that a single agent using DND can auto-failover to VM, thus causing the system to answer the call for the transfer to VM, and that VM answering the call kills the call for the other agents. VM can also be invoked if an agent has a "single-channel" sip account and is already on the phone while not in Vicidial.

2) CLI Output from a single failed call would be useful. Try to get the relevent lines instead of 3000 lines of unrelated code (which could be tough if this only happens during busy times with lots of calls). These calls are progressing in some fashion: either because they are Dropping due to exceeding the ingroup drop time or because the system believes they've been answered. Finding out which would be quite useful. Check your reports and VM boxes to see if you can get a hint in addition to the logs.

3) Seriously consider Logged In Agents instead of OnHook agents. you'll resolve this problem immediately and gain everything that Logged In Agents has to offer. If this is "don't want to because ..." instead of "can't because these agents don't have computers", rethink your answer. You don't use printed out spreadsheets and manually dial the calls (wouldn't even think of it, right?). Those who use logged in agents view "remote onhook agents" the same way. If they are logged in agents but onhook ... check to be sure ALL agents are onhook.

8-) Happy Hunting. That's all I have time for. Maybe someone else will chime in later.
Vicidial Installation and Repair, plus Hosting and Colocation
SugarCRM integration - Customization and Add-ons - We Bring It All Together.
http://www.PoundTeam.com # 352-269-0000 # +44 (203) 769-2294 # +506 4001-8914
williamconley
 
Posts: 17399
Joined: Wed Oct 31, 2007 4:17 pm
Location: Davenport, FL (By Disney!)

Re: Agents not getting calls from queue vicidial-2.9.44

Postby tarikzz » Fri Apr 27, 2018 5:22 am

Thanks William for your answer.

The freelancer who installed the system finally got us use LoggedIn agents.
Seems indeed to keep us away from a lot of signaling trouble.

Have a great day!
Linux vicibox8 4.4.140-62-default #1 SMP Tue Jul 17 12:14:34 UTC 2018 (951943d) x86_64 x86_64 x86_64 GNU/Linux
Asterisk 11.25.3-vici
Maria DB 10.2.16-MariaDB-log. Apache/2.4.23 (Linux/SUSE) PHP 5.5.14
RAM 32G
CPU x8 3.50GHz
tarikzz
 
Posts: 13
Joined: Sun Apr 15, 2018 8:02 am


Return to Support

Who is online

Users browsing this forum: No registered users and 28 guests