Calls Routing Issue

All installation and configuration problems and questions

Moderators: gerski, enjay, williamconley, Op3r, Staydog, gardo, mflorell, MJCoate, mcargile, Kumba, Michael_N

Calls Routing Issue

Postby malik » Wed Apr 19, 2017 4:59 pm

Hello Fellows,

VERSION: 2.12-560a
BUILD: 160617-1427
Asterisk Version: 11.22.0-vici

I have encountered a problem from last 2 days. agents are logged in to an outbound campaign and can make manual calls successfully but they are not getting any call dialed predicatively. most likely the issue is with extension 8369. I have tried running the calls with 8368 which worked just fine. Please suggest what to do here. Thanks,
malik
 
Posts: 9
Joined: Sat Jul 04, 2015 7:35 pm

Re: Calls Routing Issue

Postby Rogger » Wed Apr 19, 2017 8:31 pm

hello,

Are you using server or virtualization? Look at your list I believe your calls are being identified as answer machine.

Rogger
Rogger
 
Posts: 22
Joined: Fri Nov 27, 2015 9:53 am
Location: Brazil

Re: Calls Routing Issue

Postby malik » Thu Apr 20, 2017 12:07 pm

I am using server. List isn't the issue, i have used my cell phone for test purposes and when i pick up the call, I just hear silence for 10 sec and system disconnect the call after that. please see the cli report and suggest.

[Apr 20 10:06:20] -- Executing [717243058002@default:1] AGI("Local/717243058002@default-00000000;2", "agi://127.0.0.1:4577/call_log") in new stack
[Apr 20 10:06:20] -- AGI Script Executing Application: (EXEC) Options: (Set(_CAMPCUST=VIVINT))
[Apr 20 10:06:20] -- <Local/717243058002@default-00000000;2>AGI Script agi://127.0.0.1:4577/call_log completed, returning 0
[Apr 20 10:06:20] -- Executing [717243058002@default:2] Dial("Local/717243058002@default-00000000;2", "SIP/VTL/17243058002,,tTo") in new stack
[Apr 20 10:06:20] == Using SIP RTP CoS mark 5
[Apr 20 10:06:20] -- Called SIP/VTL/17243058002
[Apr 20 10:06:23] -- SIP/VTL-00000001 is making progress passing it to Local/717243058002@default-00000000;2
[Apr 20 10:06:33] -- SIP/VTL-00000001 answered Local/717243058002@default-00000000;2
[Apr 20 10:06:33] > Channel Local/717243058002@default-00000000;1 was answered
[Apr 20 10:06:33] -- Executing [8369@default:1] Playback("Local/717243058002@default-00000000;1", "sip-silence") in new stack
[Apr 20 10:06:33] -- <Local/717243058002@default-00000000;1> Playing 'sip-silence.gsm' (language 'en')
[Apr 20 10:06:33] -- Executing [8369@default:2] AGI("Local/717243058002@default-00000000;1", "agi://127.0.0.1:4577/call_log") in new stack
[Apr 20 10:06:33] -- AGI Script Executing Application: (EXEC) Options: (Set(_CAMPCUST=VIVINT))
[Apr 20 10:06:33] -- <Local/717243058002@default-00000000;1>AGI Script agi://127.0.0.1:4577/call_log completed, returning 0
[Apr 20 10:06:33] -- Executing [8369@default:3] AMD("Local/717243058002@default-00000000;1", "2000,2000,1000,5000,120,50,4,256") in new stack
[Apr 20 10:06:33] -- AMD: Local/717243058002@default-00000000;1 7248045251 (N/A) (Fmt: slin)
[Apr 20 10:06:33] -- AMD: initialSilence [2000] greeting [2000] afterGreetingSilence [1000] totalAnalysisTime [5000] minimumWordLength [120] betweenWordsSilence [50] maximumNumberOfWords [4] silenceThreshold [256] maximumWordLength [5000]
[Apr 20 10:06:33] > 0x7fdd78014860 -- Probation passed - setting RTP source address to 66.241.99.112:15744
[Apr 20 10:06:33] -- AMD: Channel [SIP/VTL-00000001]. Changed state to STATE_IN_SILENCE
[Apr 20 10:06:33] -- Executing [h@default:1] AGI("Local/717243058002@default-00000000;2", "agi://127.0.0.1:4577/call_log--HVcauses--PRI-----NODEBUG-----16-----ANSWER-----13-----0") in new stack
[Apr 20 10:06:34] == Manager 'sendcron' logged off from 127.0.0.1
[Apr 20 10:06:34] -- <Local/717243058002@default-00000000;2>AGI Script agi://127.0.0.1:4577/call_log--HVcauses ... --13-----0 completed, returning 0
[Apr 20 10:06:34] == Spawn extension (default, 717243058002, 2) exited non-zero on 'Local/717243058002@default-00000000;2'
[Apr 20 10:06:35] -- AMD: Channel [SIP/VTL-00000001]. ANSWERING MACHINE: silenceDuration:2000 initialSilence:2000
[Apr 20 10:06:35] -- Executing [8369@default:4] AGI("SIP/VTL-00000001", "VD_amd.agi,8369") in new stack
[Apr 20 10:06:35] -- Launched AGI Script /usr/share/asterisk/agi-bin/VD_amd.agi
[Apr 20 10:06:35] -- <SIP/VTL-00000001> Playing 'sip-silence.gsm' (escape_digits=) (sample_offset 0) (language 'en')
[Apr 20 10:06:35] -- <SIP/VTL-00000001> Playing 'sip-silence.gsm' (escape_digits=) (sample_offset 0) (language 'en')
[Apr 20 10:06:35] -- <SIP/VTL-00000001>AGI Script VD_amd.agi completed, returning 4
[Apr 20 10:06:35] == Spawn extension (default, 8369, 4) exited non-zero on 'SIP/VTL-00000001'
[Apr 20 10:06:35] -- Executing [h@default:1] AGI("SIP/VTL-00000001", "agi://127.0.0.1:4577/call_log--HVcauses--PRI-----NODEBUG-----0---------------") in new stack
[Apr 20 10:06:35] -- <SIP/VTL-00000001>AGI Script agi://127.0.0.1:4577/call_log--HVcauses ... ---------- completed, returning 0
malik
 
Posts: 9
Joined: Sat Jul 04, 2015 7:35 pm

Re: Calls Routing Issue

Postby Rogger » Thu Apr 20, 2017 1:41 pm

Look this:
[Apr 20 10:06:33] -- AMD: Channel [SIP/VTL-00000001]. Changed state to STATE_IN_SILENCE
[Apr 20 10:06:35] -- AMD: Channel [SIP/VTL-00000001]. ANSWERING MACHINE: silenceDuration:2000 initialSilence:2000

When you pick up the call, you'll say something, like: hello, hi, test test... The VICIdial is identifying the silence and disconnecting the call.
Rogger
 
Posts: 22
Joined: Fri Nov 27, 2015 9:53 am
Location: Brazil

Re: Calls Routing Issue

Postby malik » Thu Apr 20, 2017 1:45 pm

I say hello all the time but system hang up the call. and the surprising thing is agent dont get the call in the agent interface.
malik
 
Posts: 9
Joined: Sat Jul 04, 2015 7:35 pm


Return to Support

Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 6 guests

cron